<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="utf-8">
<meta name="viewport" content="width=device-width,initial-scale=1">
<link href="https://thestreamable.com/assets/css/primer.barracuda.site.css?v=5f9ca298" rel="stylesheet">
<script>
'use strict';
window.lazyLoadOptions = {
    use_native: true,
    elements_selector: '.lazy'
};
window.addEventListener('LazyLoad::Initialized', function (event) {
    window.lazyLoadInstance = event.detail.instance;
}, false);
</script>
<script defer src="https://cdn.jsdelivr.net/npm/vanilla-lazyload@17.1.3/dist/lazyload.min.js" integrity="sha256-LG2BYsl7F5cfXxAualYGtC3LIgoJHCrBcEjvSFgXwgk=" crossorigin="anonymous"></script>
<title>How to Watch SMU vs. Navy on ESPN2 for Free on Apple TV, Roku, Fire TV, iOS, &amp; Android &ndash; The Streamable</title>
<meta content="On Saturday, October 31, 2020 at 7:30 PM EDT, the #22&nbsp; SMU Mustangs face the Navy Midshipmen from Gerald J. Ford Stadium in Dallas, TX. The game is airing exclusively on ESPN2 , which you can stream with a Live TV &hellip;" name="description">
<meta content="Jason Gurwin" name="author">
<meta content="en_US" property="og:locale">
<meta content="article" property="og:type">
<meta content="How to Watch SMU vs. Navy on ESPN2 for Free on Apple TV, Roku, Fire TV, iOS, &amp; Android" property="og:title">
<meta content="On Saturday, October 31, 2020 at 7:30 PM EDT, the #22&nbsp; SMU Mustangs face the Navy Midshipmen from Gerald J. Ford Stadium in Dallas, TX. The game is airing exclusively on ESPN2 , which you can stream with a Live TV &hellip;" property="og:description">
<meta content="https://thestreamable.com/news/how-to-watch-smu-vs-navy-on-espn2-2020-10-31" property="og:url">
<meta content="The Streamable" property="og:site_name">
<meta content="https://www.facebook.com/thestreamable" property="article:publisher">
<meta content="https://thestreamable.com/media/pages/news/how-to-watch-smu-vs-navy-on-espn2-2020-10-31/49241f407f-1604076322/smu-mustangs-vs-navy-midshipmen-1536x864.png" property="og:image:secure_url">
<meta content="https://thestreamable.com/media/pages/news/how-to-watch-smu-vs-navy-on-espn2-2020-10-31/49241f407f-1604076322/smu-mustangs-vs-navy-midshipmen-1536x864.png" property="og:image">
<meta content="summary_large_image" name="twitter:card">
<meta content="How to Watch SMU vs. Navy on ESPN2 for Free on Apple TV, Roku, Fire TV, iOS, &amp; Android" name="twitter:title">
<meta content="On Saturday, October 31, 2020 at 7:30 PM EDT, the #22&nbsp; SMU Mustangs face the Navy Midshipmen from Gerald J. Ford Stadium in Dallas, TX. The game is airing exclusively on ESPN2 , which you can stream with a Live TV &hellip;" name="twitter:description">
<meta content="@TheStreamable" name="twitter:site">
<meta content="@TheStreamable" name="twitter:creator">
<meta content="https://thestreamable.com/media/pages/news/how-to-watch-smu-vs-navy-on-espn2-2020-10-31/49241f407f-1604076322/smu-mustangs-vs-navy-midshipmen-1536x864.png" name="twitter:image">
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-100553918-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());
  
  gtag('config', 'UA-100553918-1');
</script>
<script>
  !function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', "163394470880339");
  fbq('track', 'PageView');
</script>
<noscript>
  <img height="1" width="1" style="display:none" 
       src="https://www.facebook.com/tr?id=163394470880339&ev=PageView&noscript=1"/>
</noscript>
<meta name="fo-verify" content="9d80e29d-db65-421b-a0c9-ba45b59be9d6">
<meta name='ir-site-verification-token' value='1701667934'>
<script>
(function(w, d) {
w.adthrive = w.adthrive || {};
w.adthrive.cmd = w.adthrive.cmd || [];
w.adthrive.plugin = 'adthrive-ads-1.0.40-manual';
w.adthrive.host = 'ads.adthrive.com';
var s = d.createElement('script');
s.async = true;
s.referrerpolicy='no-referrer-when-downgrade';
s.src = 'https://' + w.adthrive.host + '/sites/5c6717f50a04d9393660fbe4/ads.min.js?referrer=' + w.encodeURIComponent(w.location.href);
var n = d.getElementsByTagName('script')[0];
n.parentNode.insertBefore(s, n);
})(window, document);
</script>
<link rel="alternate" hreflang="da-dk" href="https://thestreamable.com/dk/news/how-to-watch-smu-vs-navy-on-espn2-2020-10-31" />
<link rel="alternate" hreflang="de-de" href="https://thestreamable.com/de/nachrichten/how-to-watch-smu-vs-navy-on-espn2-2020-10-31" />
<link rel="alternate" hreflang="en-gb" href="https://thestreamable.com/uk/news/how-to-watch-smu-vs-navy-on-espn2-2020-10-31" />
<link rel="alternate" hreflang="en-us" href="https://thestreamable.com/news/how-to-watch-smu-vs-navy-on-espn2-2020-10-31" />
<link rel="alternate" hreflang="en" href="https://thestreamable.com/news/how-to-watch-smu-vs-navy-on-espn2-2020-10-31" />
<link rel="alternate" hreflang="es-es" href="https://thestreamable.com/es/noticias/how-to-watch-smu-vs-navy-on-espn2-2020-10-31" />
<link rel="alternate" hreflang="fi-fi" href="https://thestreamable.com/fi/news/how-to-watch-smu-vs-navy-on-espn2-2020-10-31" />
<link rel="alternate" hreflang="fr-fr" href="https://thestreamable.com/fr/nouvelles/how-to-watch-smu-vs-navy-on-espn2-2020-10-31" />
<link rel="alternate" hreflang="fr-lu" href="https://thestreamable.com/lu/news/how-to-watch-smu-vs-navy-on-espn2-2020-10-31" />
<link rel="alternate" hreflang="it-it" href="https://thestreamable.com/it/notizie/how-to-watch-smu-vs-navy-on-espn2-2020-10-31" />
<link rel="alternate" hreflang="ja-jp" href="https://thestreamable.com/jp/news/how-to-watch-smu-vs-navy-on-espn2-2020-10-31" />
<link rel="alternate" hreflang="nb-no" href="https://thestreamable.com/no/news/how-to-watch-smu-vs-navy-on-espn2-2020-10-31" />
<link rel="alternate" hreflang="nl-be" href="https://thestreamable.com/be/news/how-to-watch-smu-vs-navy-on-espn2-2020-10-31" />
<link rel="alternate" hreflang="pt-br" href="https://thestreamable.com/br/news/how-to-watch-smu-vs-navy-on-espn2-2020-10-31" />
<link rel="alternate" hreflang="pt-pt" href="https://thestreamable.com/pt/news/how-to-watch-smu-vs-navy-on-espn2-2020-10-31" />
<link rel="alternate" hreflang="sv-se" href="https://thestreamable.com/se/news/how-to-watch-smu-vs-navy-on-espn2-2020-10-31" />
<link rel="canonical" href="https://thestreamable.com/news/how-to-watch-smu-vs-navy-on-espn2-2020-10-31">
<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png?v=Omy9kP8XvJ">
<link rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png?v=Omy9kP8XvJ">
<link rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png?v=Omy9kP8XvJ">
<link rel="manifest" href="/manifest.json?v=Omy9kP8XvJ">
<link rel="mask-icon" href="/safari-pinned-tab.svg?v=Omy9kP8XvJ" color="#ed291b">
<link rel="shortcut icon" href="/favicon.ico?v=Omy9kP8XvJ">
<meta name="theme-color" content="#ed291b">
</head>
<body>
<a class="sr-only" href="#content">Skip to Content</a>
<header class="top-0 left-0 right-0 position-relative bg-gray-light height-site-header box-shadow position-sm-fixed" style="z-index: 32;">
<div class="px-3 d-sm-flex flex-row flex-items-center flex-justify-between container-xl" style="z-index: 1;">
<div class="flex-1 d-flex flex-items-center flex-justify-center flex-sm-justify-start flex-md-justify-center height-site-header-general-row">
<a class="d-inline-flex flex-items-center flex-justify-center bg-blue-light-hover py-2 pl-2 pr-1 ml-n2 rounded-1 mt-1 mt-sm-0" href="https://thestreamable.com"><img src="https://thestreamable.com/assets/images/the_streamable_logo.svg?v=5f9ca298" alt="The&#x20;Streamable" height="24" width="184">
</a>
</div>
<div class="d-flex mx-md-3 height-site-header-general-row flex-items-center flex-justify-center flex-sm-justify-end flex-md-justify-center" style="max-width: 480px; flex-grow: 1.4; flex-shrink: 2; flex-basis: 0; z-index: 5;">
<div id="site-header-search-overlay" hidden class="position-fixed top-0 left-0 right-0 bottom-0 cursor-pointer " style="background-color: rgba(27,31,35,0.5);"></div>
<form action="https://thestreamable.com/search" class="position-relative flex-auto">
<label class="text-normal">
<input id="site-header-search-input" class="form-control input-block input-show-webkit-search-cancel input-field-loadable py-2-focus f4 site-header-search-magnifying-glass-icon pl-7 pr-2" type="search" name="q" placeholder="Search" autocapitalize="off" spellcheck="false" style="transition: padding-top ease-out 0.1s, padding-bottom ease-out 0.1s, box-shadow ease-out 0.1s; ">
<span class="d-none d-md-inline-block input-field-keyboard-shortcut-icon right-2">/</span>
<span class="input-field-loading-spinner left-3"></span>
</label>
<input class="d-none" type="submit" value="Search">
<ul id="site-header-search-autocomplete-results" hidden class="autocomplete-results border-0 mt-1" style="max-height: 70vh; ">
<div class="px-3 px-md-4 my-3 text-gray">
<p class="f3 text-center">Search for movies, TV shows, channels, sports teams, streaming services, apps, and devices.</p>
</div>
</ul>
</form>
<script type="module">
    import { get } from "https://thestreamable.com/assets/js/modules/ajax.js?v=5f9ca298";
    import { setUpSearchFieldAutocomplete, bindSearchFieldInputFocusToKeyboardShortcut } from "https://thestreamable.com/assets/js/modules/site-search.js?v=5f9ca298";
    
    const siteSearchInput = document.getElementById('site-header-search-input');
    const siteSearchOverlay = document.getElementById('site-header-search-overlay');
    const siteSearchResultsContainer = document.getElementById('site-header-search-autocomplete-results');
    const siteSearchAjaxURL = "https://thestreamable.com/ajax/search/v1/autocomplete";
    const minWindowWidthForAutoFocus = 544;
    const minWindowHeightForAutoFocus = 720;
    
        if (!siteSearchInput.value) {
        siteSearchInput.value = sessionStorage.getItem('site-search$text');
    }
        
    siteSearchInput.addEventListener('input', function () {
        sessionStorage.setItem('site-search$text', siteSearchInput.value);
    });
    
    setUpSearchFieldAutocomplete(siteSearchInput, siteSearchOverlay, siteSearchResultsContainer, get, siteSearchAjaxURL);
    bindSearchFieldInputFocusToKeyboardShortcut(siteSearchInput);
    
    </script>
</div>
<div class="flex-1 flex-shrink-0 d-none d-md-flex f5 height-site-header-general-row flex-items-center flex-justify-center">
<div class="BtnGroup flex-shrink-0">
<a class="btn BtnGroup-item btn-sm" href="https://thestreamable.com/newsletter">
<svg class="octicon mail mr-1" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 16 16" width="14" height="16"><path fill-rule="evenodd" d="M1.75 2A1.75 1.75 0 000 3.75v.736a.75.75 0 000 .027v7.737C0 13.216.784 14 1.75 14h12.5A1.75 1.75 0 0016 12.25v-8.5A1.75 1.75 0 0014.25 2H1.75zM14.5 4.07v-.32a.25.25 0 00-.25-.25H1.75a.25.25 0 00-.25.25v.32L8 7.88l6.5-3.81zm-13 1.74v6.441c0 .138.112.25.25.25h12.5a.25.25 0 00.25-.25V5.809L8.38 9.397a.75.75 0 01-.76 0L1.5 5.809z"></path></svg>
Newsletter </a>
<a class="btn BtnGroup-item btn-sm" href="https://www.facebook.com/thestreamable" target="_blank" rel="noopener" title="Facebook">
<svg class="octicon" width="16" height="16" version="1.1" viewBox="0 0 1024 1024" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><title>Facebook</title><g fill-rule="evenodd"><path d="m512 0c-282.77 0-512 229.23-512 512 0 255.55 187.23 467.37 432 505.78h160c244.77-38.41 432-250.23 432-505.78 0-282.77-229.23-512-512-512z" fill="#1877F2" /><path d="m711.3 660 22.7-148h-142v-96.043c0-40.49 19.835-79.957 83.438-79.957h64.562v-126s-58.593-10-114.61-10c-116.95 0-193.39 70.88-193.39 199.2v112.8h-130v148h130v357.78c26.067 4.09 52.784 6.22 80 6.22s53.933-2.13 80-6.22v-357.78h119.3" fill="#fff" /></g></svg>
</a>
<a class="btn BtnGroup-item btn-sm" href="https://twitter.com/TheStreamable" target="_blank" rel="noopener" title="Twitter">
<svg class="octicon" width="16" height="16" version="1.1" viewBox="0 0 250 204" xmlns="http://www.w3.org/2000/svg"><title>Twitter</title><g fill="none" fill-rule="evenodd"><g transform="translate(-75 -98)" fill="#1DA1F2" fill-rule="nonzero"><path d="m153.62 301.59c94.34 0 145.94-78.16 145.94-145.94 0-2.22 0-4.43-0.15-6.63 10.038-7.2609 18.704-16.251 25.59-26.55-9.3612 4.148-19.292 6.8683-29.46 8.07 10.707-6.4102 18.721-16.492 22.55-28.37-10.068 5.9746-21.084 10.185-32.57 12.45-15.899-16.906-41.163-21.044-61.625-10.093-20.462 10.951-31.033 34.266-25.785 56.873-41.241-2.0675-79.665-21.547-105.71-53.59-13.614 23.436-6.6601 53.419 15.88 68.47-8.1626-0.24192-16.147-2.4439-23.28-6.42v0.65c0.0066813 24.416 17.218 45.445 41.15 50.28-7.5513 2.0594-15.474 2.3604-23.16 0.88 6.7195 20.894 25.976 35.208 47.92 35.62-18.163 14.274-40.599 22.023-63.7 22-4.081-0.007835-8.158-0.25492-12.21-0.74 23.456 15.053 50.749 23.037 78.62 23" /></g></g></svg>
</a>
<a class="btn BtnGroup-item btn-sm" href="https://www.youtube.com/TheStreamable" target="_blank" rel="noopener" title="YouTube">
<svg class="octicon" width="16" height="16" version="1.1" viewBox="0 0 176 124" xmlns="http://www.w3.org/2000/svg"><title>YouTube</title><g fill-rule="evenodd"><path d="m172.32 19.363c-2.024-7.622-7.987-13.624-15.56-15.661-13.725-3.702-68.762-3.702-68.762-3.702s-55.037 0-68.762 3.702c-7.572 2.037-13.536 8.039-15.56 15.661-3.678 13.814-3.678 42.637-3.678 42.637s0 28.822 3.678 42.638c2.024 7.621 7.988 13.623 15.56 15.661 13.725 3.701 68.762 3.701 68.762 3.701s55.037 0 68.762-3.701c7.573-2.038 13.536-8.04 15.56-15.661 3.678-13.816 3.678-42.638 3.678-42.638s0-28.823-3.678-42.637" fill="#D9252A" /><polyline points="70 88.169 116 62.001 70 35.831 70 88.169" fill="#FFFFFE" /></g></svg>
</a>
</div>
<a href="https://jobs.gohire.io/the-streamable-pqlx5fl9/" target="_blank" rel="noopener" class="d-none d-lg-inline-block btn btn-sm ml-2 ml-xl-3">Jobs</a>
</div>
</div>
<nav id="site-header-navigation" class="UnderlineNav height-site-header-nav-row overflow-visible flex-justify-center">
<div class="HoverMenu UnderlineNav-body max-width-full overflow-x-scroll overflow-md-x-visible">
<div class="HoverMenu-item-container rounded-top-2 bg-blue-light-hover d-none d-md-block">
<a class="d-block height-full HoverMenu-item-button UnderlineNav-item " href="https://thestreamable.com">Home</a>
</div>
<div class="HoverMenu-item-container rounded-top-2 bg-blue-light-hover ">
<a class="d-block height-full HoverMenu-item-button UnderlineNav-item text-bold border-gray-dark" href="https://thestreamable.com/news">News</a>
</div>
<div class="HoverMenu-item-container rounded-top-2 bg-blue-light-hover ">
<a class="d-block height-full HoverMenu-item-button UnderlineNav-item " href="https://thestreamable.com/live-tv-streaming">Live TV</a>
</div>
<div class="HoverMenu-item-container rounded-top-2 bg-blue-light-hover ">
<a class="d-block height-full HoverMenu-item-button UnderlineNav-item " href="https://thestreamable.com/video-streaming">On Demand</a>
 </div>
<div class="HoverMenu-item-container rounded-top-2 bg-blue-light-hover ">
<a class="d-block height-full HoverMenu-item-button UnderlineNav-item " href="https://thestreamable.com/channels">Channels</a>
</div>
<div class="HoverMenu-item-container rounded-top-2 bg-blue-light-hover ">
<a class="d-block height-full HoverMenu-item-button UnderlineNav-item " href="https://thestreamable.com/sports">Sports</a>
</div>
<div class="HoverMenu-item-container rounded-top-2 bg-blue-light-hover ">
<a class="d-block height-full HoverMenu-item-button UnderlineNav-item " href="https://thestreamable.com/movies">Movies</a>
</div>
<div class="HoverMenu-item-container rounded-top-2 bg-blue-light-hover ">
<a class="d-block height-full HoverMenu-item-button UnderlineNav-item " href="https://thestreamable.com/shows">TV Shows</a>
</div>
<div class="HoverMenu-item-container rounded-top-2 bg-blue-light-hover ">
<a class="d-block height-full HoverMenu-item-button UnderlineNav-item " href="https://thestreamable.com/streaming-devices">Devices</a>
</div>
<div class="HoverMenu-item-container rounded-top-2 bg-blue-light-hover ">
<a class="d-block height-full HoverMenu-item-button UnderlineNav-item " href="https://thestreamable.com/tv-everywhere-apps">TVE Apps</a>
</div>
<div class="HoverMenu-item-container rounded-top-2 bg-blue-light-hover ">
<a class="d-block height-full HoverMenu-item-button UnderlineNav-item " href="https://thestreamable.com/vpns">VPNs</a>
</div>
</div>
</nav>
</header>
<script type="module">
    import { get } from "https://thestreamable.com/assets/js/modules/ajax.js?v=5f9ca298";
    
    const siteHeaderNavID = 'site-header-navigation';
    const siteHeaderNav = document.getElementById(siteHeaderNavID);
    const siteHeaderNavAjaxURL = "https://thestreamable.com/ajax/navbar/v1/navigation?pageID=news/how-to-watch-smu-vs-navy-on-espn2-2020-10-31";
    const minWindowWidthForNavBarDropdowns = 768;
    if (window.innerWidth >= minWindowWidthForNavBarDropdowns) {
        get(siteHeaderNavAjaxURL).then(function (response) {
            const responseDOM = new DOMParser().parseFromString(response, "text/html");
            const responseHeaderNav = responseDOM.getElementById(siteHeaderNavID);
            if (responseHeaderNav) {
                siteHeaderNav.innerHTML = responseHeaderNav.innerHTML;
                if (window.lazyLoadInstance) {
                    window.lazyLoadInstance.update();
                }
            }
        })
        .catch (function (error) {
        });
    }
</script>
<div class="position-relative mt-sm-site-header-height">
<div class="d-none d-lg-block position-absolute right-0 top-0 bottom-0 border-left bg-gray-light-extra width-site-ad-sidebar" style="box-sizing:content-box;">
<div id="adthrive-sidebar-ad" class="position-sticky top-sm-site-header-height overflow-hidden"></div>
</div>
<div class="position-relative clearfix mr-lg-site-ad-sidebar-width">

<link href="https://thestreamable.com/assets/css/legacy-site.css?v=5f9ca298" rel="stylesheet">

<div class="my-3">
<div class="d-none d-md-flex mt-n2 mb-2 flex-items-center flex-justify-center" style="height:100px;">

<div id="adthrive-header-ad" class="width-fit height-fit overflow-hidden site-header-wrap"></div>
</div>
<aside class="text-small text-gray-light text-center mx-3 lh-condensed-ultra">
<p class="m-0">The Streamable is reader-supported and may earn an affiliate commission when you sign up with our links.</p>
</aside>
</div>
<div class="px-4 px-md-5 pb-6">
<main id="content" class="container-md">

<article class="main-content-amnis">

<div class="mb-4 lh-condensed">
<nav aria-label="Breadcrumb" class="">
<ol>
<li class="breadcrumb-item text-small breadcrumb-item-selected"><a href="https://thestreamable.com/news">News &amp; Updates</a></li>
</ol>
</nav>
<h1 class="mt-3">How to Watch SMU vs. Navy on ESPN2 for Free on Apple TV, Roku, Fire TV, iOS, &amp; Android</h1>
<div class="mt-2 f4 text-gray-light">
<strong class="text-uppercase"><time datetime="2020-10-30T15:43:00-07:00">Oct 30, 2020, 3:43 PM PDT</time></strong>
<span> <span class="mx-1">&ndash;</span>
<a class="text-inherit link-hover-blue" href="https://thestreamable.com/people/jason-gurwin">Jason Gurwin</a> </span>
</div>
</div>
<div class="my-4">
<figure class="mx-auto" style="max-width:768px;">
<div class="position-relative width-full" style="padding-bottom:56.25000%;">
<img src="https://thestreamable.com/media/pages/news/how-to-watch-smu-vs-navy-on-espn2-2020-10-31/49241f407f-1604076322/smu-mustangs-vs-navy-midshipmen-768x432.png" srcset="https://thestreamable.com/media/pages/news/how-to-watch-smu-vs-navy-on-espn2-2020-10-31/49241f407f-1604076322/smu-mustangs-vs-navy-midshipmen-384x216.png 384w, https://thestreamable.com/media/pages/news/how-to-watch-smu-vs-navy-on-espn2-2020-10-31/49241f407f-1604076322/smu-mustangs-vs-navy-midshipmen-576x324.png 576w, https://thestreamable.com/media/pages/news/how-to-watch-smu-vs-navy-on-espn2-2020-10-31/49241f407f-1604076322/smu-mustangs-vs-navy-midshipmen-768x432.png 768w, https://thestreamable.com/media/pages/news/how-to-watch-smu-vs-navy-on-espn2-2020-10-31/49241f407f-1604076322/smu-mustangs-vs-navy-midshipmen-960x540.png 960w, https://thestreamable.com/media/pages/news/how-to-watch-smu-vs-navy-on-espn2-2020-10-31/49241f407f-1604076322/smu-mustangs-vs-navy-midshipmen-1152x648.png 1152w, https://thestreamable.com/media/pages/news/how-to-watch-smu-vs-navy-on-espn2-2020-10-31/49241f407f-1604076322/smu-mustangs-vs-navy-midshipmen-1536x864.png 1536w" sizes="(min-width: 768px) 768px, 100vw" width="768" height="432" class="position-absolute top-0 bottom-0 left-0 right-0 width-full height-full bg-gray rounded-2 box-shadow-large">
</div>
</figure>
</div>
<div class="markdown-body width-fit">
<p>On Saturday, October 31, 2020 at 7:30 PM EDT, the #22&#160;<a href="https://thestreamable.com/sports/ncaa-football/smu-mustangs">SMU Mustangs</a> face the <a href="https://thestreamable.com/sports/ncaa-football/navy-midshipmen">Navy Midshipmen</a> from Gerald J. Ford Stadium in Dallas, TX. The game is airing exclusively on <a href="https://thestreamable.com/channels/espn2">ESPN2</a>, which you can stream with a <a href="https://thestreamable.com/live-tv-streaming">Live TV Streaming Service</a>.</p>
<h2 id="smu-mustangs-vs-navy-midshipmen">SMU Mustangs vs. Navy Midshipmen</h2>
<ul>
<li>When: Saturday, October 31, 2020 at 7:30 PM EDT</li>
<li>TV: <a href="https://thestreamable.com/channels/espn2">ESPN2</a></li>
<li>Stream: Watch with <a href="https://thestreamable.com/live-tv-streaming/fubotv/buy" target="_blank" rel="noopener">7-Day Free Trial of fuboTV</a><nav class="buy-block"><a href="https://thestreamable.com/live-tv-streaming/fubotv/buy" target="_blank" rel="noopener" class="buy-block-cta no-underline">7-Day Free Trial</a><div class="buy-block-info">
<strong>$59.99 / month</strong> <a href="https://thestreamable.com/live-tv-streaming/fubotv/buy" target="_blank" rel="noopener">fubo.tv</a>
</div></nav>
</li>
</ul>
<p>You can stream this game without cable with a <a href="https://thestreamable.com/live-tv-streaming">Live TV Streaming Service</a> like <a href="https://thestreamable.com/live-tv-streaming/fubotv/buy" rel="noopener" target="_blank">fuboTV</a>, <a href="https://thestreamable.com/live-tv-streaming/hulu-live-tv/buy" rel="noopener" target="_blank">Hulu Live TV</a>, <a href="https://thestreamable.com/live-tv-streaming/sling-tv/buy" rel="noopener" target="_blank">Sling TV</a>, <a href="https://thestreamable.com/live-tv-streaming/youtube-tv/buy" rel="noopener" target="_blank">YouTube TV</a>, and <a href="https://thestreamable.com/live-tv-streaming/att-tv-now/buy" rel="noopener" target="_blank">AT&amp;T TV NOW</a>. If you haven’t tried it before, you can get a <a href="https://thestreamable.com/live-tv-streaming/fubotv/buy" target="_blank" rel="noopener">7-Day Free Trial of fuboTV</a>.</p>
<figure class="wide-table-wrapper"><table class="comparison-table sticky-headers highlight-row-via-header"><thead><tr><th class="header-gap"></th><th class="zig-column"><a href="https://thestreamable.com/live-tv-streaming/att-tv-now">AT&T&nbsp;NOW</a></th><th class="zag-column"><a href="https://thestreamable.com/live-tv-streaming/fubotv">fuboTV</a></th><th class="zig-column"><a href="https://thestreamable.com/live-tv-streaming/hulu-live-tv">Hulu</a></th><th class="zag-column"><a href="https://thestreamable.com/live-tv-streaming/philo">Philo</a></th><th colspan="2" class="zig-column"><a href="https://thestreamable.com/live-tv-streaming/sling-tv">Sling&nbsp;TV</a></th><th class="zag-column"><a href="https://thestreamable.com/live-tv-streaming/youtube-tv">YouTube</a></th></tr><tr class="secondary signups"><th class="header-gap"></th><th class="zig-column"><a href="https://thestreamable.com/live-tv-streaming/att-tv-now/buy" target="_blank" rel="noopener" class="no-thick text-underline link-gray-light">Sign&nbsp;Up</a></th><th class="zag-column"><a href="https://thestreamable.com/live-tv-streaming/fubotv/buy" target="_blank" rel="noopener" class="no-thick text-underline link-gray-light">Free&nbsp;Trial</a></th><th class="zig-column"><a href="https://thestreamable.com/live-tv-streaming/hulu-live-tv/buy" target="_blank" rel="noopener" class="no-thick text-underline link-gray-light">Free&nbsp;Trial</a></th><th class="zag-column"><a href="https://thestreamable.com/live-tv-streaming/philo/buy" target="_blank" rel="noopener" class="no-thick text-underline link-gray-light">Free&nbsp;Trial</a></th><th colspan="2" class="zig-column"><a href="https://thestreamable.com/live-tv-streaming/sling-tv/buy" target="_blank" rel="noopener" class="no-thick text-underline link-gray-light">Sign&nbsp;Up</a></th><th class="zag-column"><a href="https://thestreamable.com/live-tv-streaming/youtube-tv/buy" target="_blank" rel="noopener" class="no-thick text-underline link-gray-light">Sign&nbsp;Up</a></th></tr><tr class="pricing secondary"><th class="header-gap"></th><th class="zig-column"><a href="https://thestreamable.com/live-tv-streaming/att-tv-now/buy" target="_blank" rel="noopener">$54.99</a></th><th class="zag-column"><a href="https://thestreamable.com/live-tv-streaming/fubotv/buy" target="_blank" rel="noopener">$59.99</a></th><th class="zig-column"><a href="https://thestreamable.com/live-tv-streaming/hulu-live-tv/buy" target="_blank" rel="noopener">$54.99</a></th><th class="zag-column"><a href="https://thestreamable.com/live-tv-streaming/philo/buy" target="_blank" rel="noopener">$20</a></th><th class="zig-column"><a href="https://thestreamable.com/live-tv-streaming/sling-tv/buy" target="_blank" rel="noopener">$30</a></th><th class="zig-column"><a href="https://thestreamable.com/live-tv-streaming/sling-tv/buy" target="_blank" rel="noopener">$30</a></th><th class="zag-column"><a href="https://thestreamable.com/live-tv-streaming/youtube-tv/buy" target="_blank" rel="noopener">$64.99</a></th></tr></thead><tbody><tr><th scope="row"><a href="https://thestreamable.com/channels/espn2">ESPN2</a></th><td class="zig-column"><span class="indicator-circle-green present-indicator">•</span></td><td class="zag-column"><span class="indicator-circle-green present-indicator">•</span></td><td class="zig-column"><span class="indicator-circle-green present-indicator">•</span></td><td class="zag-column"><span class="indicator-circle-gray-outline absent-indicator">-</span></td><td class="zig-column"><span class="indicator-circle-green present-indicator">•</span></td><td class="zig-column"><span class="indicator-circle-gray-outline absent-indicator">-</span></td><td class="zag-column"><span class="indicator-circle-green present-indicator">•</span></td></tr></tbody></table></figure>
<h2 id="suggestions" class="page-cut-heading"><span>All Live TV Streaming Options</span></h2>
<div class="content-columns content-columns-2 content-columns-1-compact">
<div class="content-column">
<h3 id="fubotv" class="mt-3"><a href="https://thestreamable.com/live-tv-streaming/fubotv/buy" target="_blank" rel="noopener" style="border: none;"><img data-src="https://thestreamable.com/media/pages/live-tv-streaming/fubotv/9bb221c272-1603144662/fubotv-logo.svg" alt="fuboTV" title="" height="40" width="111" class="lazy " style="">
</a></h3>
<p><strong>Price:</strong> $59.99<br><strong>Includes:</strong> ESPN2&#160;<span class="text-gray">+ 30 Top Cable Channels</span></p> <nav class="buy-block-cara"><a href="https://thestreamable.com/live-tv-streaming/fubotv/buy" target="_blank" rel="noopener" class="buy-block-cara-cta no-underline">7-Day Free Trial</a><div class="buy-block-cara-info">
<strong class="buy-block-cara-price">$59.99 / month</strong> <a class="no-thick buy-block-cara-source" href="https://thestreamable.com/live-tv-streaming/fubotv/buy" target="_blank" rel="noopener">fubo.tv</a>
</div></nav> </div>
<div class="content-column">
<h3 id="hulu-live-tv" class="mt-3"><a href="https://thestreamable.com/live-tv-streaming/hulu-live-tv/buy" target="_blank" rel="noopener" style="border: none;"><img data-src="https://thestreamable.com/media/pages/live-tv-streaming/hulu-live-tv/b5762b9f78-1603144662/hulu-logo.svg" alt="Hulu&#x20;Live&#x20;TV" title="" height="40" width="122" class="lazy " style="">
</a></h3>
<p><strong>Price:</strong> $54.99<br><strong>Includes:</strong> ESPN2&#160;<span class="text-gray">+ 26 Top Cable Channels</span></p> <nav class="buy-block-cara"><a href="https://thestreamable.com/live-tv-streaming/hulu-live-tv/buy" target="_blank" rel="noopener" class="buy-block-cara-cta no-underline">7-Day Free Trial</a><div class="buy-block-cara-info">
<strong class="buy-block-cara-price">$54.99 / month</strong> <a class="no-thick buy-block-cara-source" href="https://thestreamable.com/live-tv-streaming/hulu-live-tv/buy" target="_blank" rel="noopener">hulu.com</a>
</div><div class="buy-block-cara-promo"><p>Get Hulu Originals for <strong>FREE</strong> ($6) with subscription</p></div></nav> </div>
<div class="content-column">
<h3 id="sling-tv" class="mt-3"><a href="https://thestreamable.com/live-tv-streaming/sling-tv/buy" target="_blank" rel="noopener" style="border: none;"><img data-src="https://thestreamable.com/media/pages/live-tv-streaming/sling-tv/79550adff8-1603144662/sling-logo.svg" alt="Sling&#x20;TV" title="" height="40" width="76" class="lazy " style="">
</a></h3>
<p><strong>Price:</strong> $30<br><strong>Includes:</strong> ESPN2&#160;<span class="text-gray">+ 16 Top Cable Channels</span></p> <nav class="buy-block-cara"><a href="https://thestreamable.com/live-tv-streaming/sling-tv/buy" target="_blank" rel="noopener" class="buy-block-cara-cta no-underline">Sign Up</a><div class="buy-block-cara-info">
<strong class="buy-block-cara-price">$30 / month</strong> <a class="no-thick buy-block-cara-source" href="https://thestreamable.com/live-tv-streaming/sling-tv/buy" target="_blank" rel="noopener">sling.com</a>
</div><div class="buy-block-cara-promo"><p>Get $10 OFF Your First Month &amp; Showtime, STARZ, &amp; EPIX For Free For 30 Days.</p></div></nav> </div>
<div class="content-column">
<h3 id="youtube-tv" class="mt-3"><a href="https://thestreamable.com/live-tv-streaming/youtube-tv/buy" target="_blank" rel="noopener" style="border: none;"><img data-src="https://thestreamable.com/media/pages/live-tv-streaming/youtube-tv/805f3c08fd-1603144662/youtube-tv-logo.svg" alt="YouTube&#x20;TV" title="" height="23" width="128" class="lazy " style="">
</a></h3>
<p><strong>Price:</strong> $64.99<br><strong>Includes:</strong> ESPN2&#160;<span class="text-gray">+ 31 Top Cable Channels</span></p> <nav class="buy-block-cara"><a href="https://thestreamable.com/live-tv-streaming/youtube-tv/buy" target="_blank" rel="noopener" class="buy-block-cara-cta no-underline">Sign Up</a><div class="buy-block-cara-info">
<strong class="buy-block-cara-price">$64.99 / month</strong> <a class="no-thick buy-block-cara-source" href="https://thestreamable.com/live-tv-streaming/youtube-tv/buy" target="_blank" rel="noopener">tv.youtube.com</a>
</div></nav> </div>
<div class="content-column">
<h3 id="att-tv-now" class="mt-3"><a href="https://thestreamable.com/live-tv-streaming/att-tv-now/buy" target="_blank" rel="noopener" style="border: none;"><img data-src="https://thestreamable.com/media/pages/live-tv-streaming/att-tv-now/8675746af6-1603144662/att-tv-now-logo.svg" alt="AT&amp;T&#x20;TV&#x20;NOW" title="" height="40" width="93" class="lazy " style="">
</a></h3>
<p><strong>Price:</strong> $54.99<br><strong>Includes:</strong> ESPN2&#160;<span class="text-gray">+ 23 Top Cable Channels</span></p> <nav class="buy-block-cara"><a href="https://thestreamable.com/live-tv-streaming/att-tv-now/buy" target="_blank" rel="noopener" class="buy-block-cara-cta no-underline">Sign Up</a><div class="buy-block-cara-info">
<strong class="buy-block-cara-price">$54.99 / month</strong> <a class="no-thick buy-block-cara-source" href="https://thestreamable.com/live-tv-streaming/att-tv-now/buy" target="_blank" rel="noopener">atttvnow.com</a>
</div></nav> </div>
</div>
</div>

</article>
</main>
<div class="container-lg mt-6">
<aside class="position-relative container-sm mb-7 box-shadow border bg-gray-light pt-5 pb-5 pb-sm-6 px-5 rounded-3 text-center text-sm-left d-flex flex-column flex-sm-row flex-items-start flex-justify-center" style="width:fit-content;">
<div class="mx-auto mb-2 mb-sm-0 mt-sm-3 mr-sm-4"><div class="mx-auto position-relative border-top border-gray-light rounded-2" style="width:54px;height:36px;">
<div class="rounded-2 position-absolute top-0 left-0 right-0 bottom-0 bg-gray-0 box-shadow" style="background-image:linear-gradient(#f6f8fa,#e1e4e8);"></div>
<div class="rounded-2 position-absolute top-0 left-0 right-0 bottom-0" style="border-width:27px 27px 9px;border-color:#d1d5da transparent transparent;border-style:solid;"></div>
<div class="rounded-2 position-absolute top-0 left-0 right-0 bottom-0" style="border-width:25px 27px 11px;border-color:#fafbfc transparent transparent;border-style:solid;"></div>
<div class="circle bg-site-red position-absolute" style="top:-8px;right:-8px;width:18px;height:18px;box-shadow:0 1px 0 rgba(27,31,35,0.15);"></div>
</div>
</div>
<div>
<div class="mb-3">
<h2 class="lh-condensed mb-1">Become a Streaming Insider!</h2>
<div class="text-gray f5">Get insider tips, top news stories, and the best streaming deals in your inbox.</div>
</div>
<form class="mb-n3" action="https://newsletter.thestreamable.com/subscribe" method="POST" accept-charset="utf-8" onsubmit="const emailField = document.getElementById('newsletter-ROF31PlH-email-input'); emailField.value = emailField.value.trim();" target="_blank" rel="noopener">
<input id="newsletter-ROF31PlH-email-input" class="form-control input-lg text-normal mb-3" name="email" type="email" placeholder="you@example.com" required 0="aria-label" 1="Email Address" oninput="document.getElementById('newsletter-ROF31PlH-submit-button').disabled = !this.value.length;" />
<label class="d-none">HP<input name="hp" type="text" /></label>
<input type="hidden" name="list" value="QubTNq30QemE892pWRzIxJWQ" />
<input type="hidden" name="subform" value="yes" />
<input type="hidden" name="ReferralID" />
<button id="newsletter-ROF31PlH-submit-button" class="ml-2 mb-3 btn btn-primary" type="submit" name="submit">Subscribe for Free</button>
</form>
<script type="module">
    const newsletterEmailField = document.getElementById('newsletter-ROF31PlH-email-input');
    document.getElementById('newsletter-ROF31PlH-submit-button').disabled = !newsletterEmailField.value;
    
</script>
</div>
</aside>
<aside data-limit="8" id="recent-news-ajax-94862084244"></aside>
<script type="module">
    import { get } from "https://thestreamable.com/assets/js/modules/ajax.js?v=5f9ca298";
    
    let recentNewsPath = "https://thestreamable.com/ajax/v1/recent-news?limit=9";
    let excludedIDs = ["news/how-to-watch-smu-vs-navy-on-espn2-2020-10-31"];
    
    get(recentNewsPath).then(function(recentNews) {
        let recentNewsContainer = document.getElementById("recent-news-ajax-94862084244");
        recentNewsContainer.innerHTML = recentNews;
        
        let articles = recentNewsContainer.querySelectorAll('article');
        
        let limit = recentNewsContainer.getAttribute('data-limit') || articles.length;
        var visibleCount = 0;
        
        articles.forEach(function (article) {
            if (excludedIDs.indexOf(article.getAttribute('data-page-id')) != -1 || ++visibleCount > limit) {
                article.remove();
            }
        });
        
        if (window.lazyLoadInstance) {
            window.lazyLoadInstance.update();
        }
    }).catch(function (error) {
        // Couldn't load recent news
    });
</script>
</div>
</div>
<footer id="footer" class="bg-gray border-top p-4 p-md-7">
<div class="container-xl">
<div class="clearfix gutter">
<div class="float-left col-12 col-sm-8">
<a class="no-underline mb-3 d-inline-block opacity-8 opacity-10-hover" href="https://thestreamable.com" style="line-height: 0;"><img src="https://thestreamable.com/assets/images/the_streamable_logo.svg?v=5f9ca298" alt="The&#x20;Streamable" height="24" width="184">
</a>
<p>The Streamable provides in-depth testing and reporting on streaming services, devices, internet, &amp; cell phone plans. When you shop through our picks, we may earn a commission.</p> </div>
<div class="float-left col-12 col-sm-4 mt-2 mt-sm-0">
<h5 class="mb-1 mb-sm-2">Connect with Us</h5>
<ul class="list-style-none">
<li class="d-inline-block mr-2">
<a href="/people" target="_blank" rel="noopener" class="link-gray text-underline">About Us</a>
</li>
<li class="d-inline-block mr-2">
<a href="https://www.facebook.com/thestreamable" target="_blank" rel="noopener" class="link-gray text-underline">Facebook</a>
</li>
<li class="d-inline-block mr-2">
<a href="https://twitter.com/TheStreamable" target="_blank" rel="noopener" class="link-gray text-underline">Twitter</a>
</li>
<li class="d-inline-block mr-2">
<a href="https://www.instagram.com/thestreamable/" target="_blank" rel="noopener" class="link-gray text-underline">Instagram</a>
</li>
<li class="d-inline-block mr-2">
<a href="https://www.youtube.com/TheStreamable" target="_blank" rel="noopener" class="link-gray text-underline">YouTube</a>
</li>
<li class="d-inline-block mr-2">
<a href="/cdn-cgi/l/email-protection#3c55525a537c4854594f484e595d515d5e5059125f5351" target="_blank" rel="noopener" class="link-gray text-underline">Email</a>
</li>
</ul>
</div>
<div class="float-right col-12 col-sm-4 mt-4">
<details class="dropdown details-reset details-overlay d-inline-block">
<summary class="btn btn-sm" aria-haspopup="true">
<span class="mr-1">🇺🇸</span>
United States <span class="text-gray">(English)</span>
<div class="dropdown-caret"></div>
</summary>
<ul class="dropdown-menu dropdown-menu-ne" style="width: 240px;">
<li>
<a href="https://thestreamable.com/news/how-to-watch-smu-vs-navy-on-espn2-2020-10-31" class="dropdown-item text-bold">
<span class="mr-1">🇺🇸</span>
United States <span class="opacity-8">(English)</span>
</a>
</li>
<li>
<a href="https://thestreamable.com/dk/news/how-to-watch-smu-vs-navy-on-espn2-2020-10-31" class="dropdown-item ">
<span class="mr-1">🇩🇰</span>
Denmark <span class="opacity-8">(Danish)</span>
</a>
</li>
<li>
<a href="https://thestreamable.com/be/news/how-to-watch-smu-vs-navy-on-espn2-2020-10-31" class="dropdown-item ">
<span class="mr-1">🇧🇪</span>
Belgium  <span class="opacity-8">(Dutch)</span>
</a>
</li>
<li>
<a href="https://thestreamable.com/uk/news/how-to-watch-smu-vs-navy-on-espn2-2020-10-31" class="dropdown-item ">
<span class="mr-1">🇬🇧</span>
United Kingdom <span class="opacity-8">(English)</span>
</a>
</li>
<li>
<a href="https://thestreamable.com/fi/news/how-to-watch-smu-vs-navy-on-espn2-2020-10-31" class="dropdown-item ">
<span class="mr-1">🇫🇮</span>
Finland <span class="opacity-8">(Finnish)</span>
</a>
</li>
<li>
<a href="https://thestreamable.com/fr/nouvelles/how-to-watch-smu-vs-navy-on-espn2-2020-10-31" class="dropdown-item ">
<span class="mr-1">🇫🇷</span>
France <span class="opacity-8">(French)</span>
</a>
</li>
<li>
<a href="https://thestreamable.com/lu/news/how-to-watch-smu-vs-navy-on-espn2-2020-10-31" class="dropdown-item ">
<span class="mr-1">🇱🇺</span>
Luxembourg <span class="opacity-8">(French)</span>
</a>
</li>
<li>
<a href="https://thestreamable.com/de/nachrichten/how-to-watch-smu-vs-navy-on-espn2-2020-10-31" class="dropdown-item ">
<span class="mr-1">🇩🇪</span>
Germany <span class="opacity-8">(German)</span>
</a>
</li>
<li>
<a href="https://thestreamable.com/it/notizie/how-to-watch-smu-vs-navy-on-espn2-2020-10-31" class="dropdown-item ">
<span class="mr-1">🇮🇹</span>
Italy <span class="opacity-8">(Italian)</span>
</a>
</li>
<li>
<a href="https://thestreamable.com/jp/news/how-to-watch-smu-vs-navy-on-espn2-2020-10-31" class="dropdown-item ">
<span class="mr-1">🇯🇵</span>
Japan <span class="opacity-8">(Japanese)</span>
</a>
</li>
<li>
<a href="https://thestreamable.com/no/news/how-to-watch-smu-vs-navy-on-espn2-2020-10-31" class="dropdown-item ">
<span class="mr-1">🇳🇴</span>
Norway <span class="opacity-8">(Norwegian)</span>
</a>
</li>
<li>
<a href="https://thestreamable.com/br/news/how-to-watch-smu-vs-navy-on-espn2-2020-10-31" class="dropdown-item ">
<span class="mr-1">🇧🇷</span>
Brazil <span class="opacity-8">(Portuguese)</span>
</a>
</li>
<li>
<a href="https://thestreamable.com/pt/news/how-to-watch-smu-vs-navy-on-espn2-2020-10-31" class="dropdown-item ">
<span class="mr-1">🇵🇹</span>
Portugal <span class="opacity-8">(Portuguese)</span>
</a>
</li>
<li>
<a href="https://thestreamable.com/es/noticias/how-to-watch-smu-vs-navy-on-espn2-2020-10-31" class="dropdown-item ">
<span class="mr-1">🇪🇸</span>
Spain <span class="opacity-8">(Spanish)</span>
</a>
</li>
<li>
<a href="https://thestreamable.com/se/news/how-to-watch-smu-vs-navy-on-espn2-2020-10-31" class="dropdown-item ">
<span class="mr-1">🇸🇪</span>
Sweden <span class="opacity-8">(Swedish)</span>
</a>
</li>
</ul>
</details>
</div>
<div class="float-right col-12 col-sm-8 mt-4">
<p class="text-gray mb-0">© 2020 FOMOPOP, Inc. 2 Harrison Street, San Francisco, CA 94105 – <a href="https://thestreamable.com/privacy-policy">Privacy Policy</a></p>
</div>
</div>
</div>
</footer>

<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="application/ld+json">
{"@context":"http:\/\/schema.org\/","@type":"NewsArticle","@id":"https:\/\/thestreamable.com\/news\/how-to-watch-smu-vs-navy-on-espn2-2020-10-31","url":"https:\/\/thestreamable.com\/news\/how-to-watch-smu-vs-navy-on-espn2-2020-10-31","headline":"How to Watch SMU vs. Navy on ESPN2 for Free on Apple TV, Roku, Fire TV, iOS, & Android","publisher":{"@context":"http:\/\/schema.org\/","@type":"Organization","@id":"https:\/\/thestreamable.com#organization","url":"https:\/\/thestreamable.com","name":"The Streamable","sameAs":["https:\/\/www.facebook.com\/thestreamable","https:\/\/twitter.com\/TheStreamable","https:\/\/www.instagram.com\/thestreamable\/","https:\/\/www.youtube.com\/TheStreamable"],"logo":{"type":"ImageObject","url":"https:\/\/thestreamable.com\/assets\/images\/the_streamable_logo.png?v=5f9ca298","width":429,"height":60}},"description":"On Saturday, October 31, 2020 at 7:30 PM EDT, the #22&#160; SMU Mustangs face the Navy Midshipmen from Gerald J. Ford Stadium in Dallas, TX. The game is airing exclusively on ESPN2 , which you can stream with a Live TV \u2026","author":{"@context":"http:\/\/schema.org\/","@type":"Person","name":"Jason Gurwin"},"datePublished":"2020-10-30T15:43:00-07:00","dateModified":"2020-10-30T15:43:00-07:00","image":"https:\/\/thestreamable.com\/media\/pages\/news\/how-to-watch-smu-vs-navy-on-espn2-2020-10-31\/49241f407f-1604076322\/smu-mustangs-vs-navy-midshipmen.png"}</script>

</div>
<div id="content-scroll-sentinel-halfway" class="v-hidden position-absolute left-0" style="width:1px;height:1px;top:40%"></div>
</div>
<div class="position-sticky bottom-0 left-0 right-0 border-top bg-blur-lightest overflow-hidden" style="z-index:28;">
<div id="adthrive-footer-ad" class="mx-auto" style="max-height:100px;width:max-content;"></div>
 <button type="button" class="lh-condensed-ultra close-button position-absolute top-1 right-1 right-md-3 text-gray" aria-label="Close" onclick="this.parentElement.remove();">
<div class="p-1 bg-white bg-gray-hover circle">
<svg width="16" height="16" viewBox="0 0 12 16" class="octicon octicon-x" aria-hidden="true"><path fill-rule="evenodd" d="M7.48 8l3.75 3.75-1.48 1.48L6 9.48l-3.75 3.75-1.48-1.48L4.52 8 .77 4.25l1.48-1.48L6 6.52l3.75-3.75 1.48 1.48L7.48 8z" /></svg>
</div>
</button>
</div>
<script type="application/ld+json">{"@context":"https:\/\/schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"name":"News","item":"https:\/\/thestreamable.com\/news"},{"@type":"ListItem","position":2,"name":"How to Watch SMU vs. Navy on ESPN2 for Free on Apple TV, Roku, Fire TV, iOS, & Android","item":"https:\/\/thestreamable.com\/news\/how-to-watch-smu-vs-navy-on-espn2-2020-10-31"}]}</script>

<script type="text/javascript">
  (function (d){
   var elements = d.querySelectorAll('.main-content-amnis .markdown-body > .buy-block');
    for (var e of elements) {
        e.previousElementSibling.classList.add('buy-block-sibling');
    }
  })(document)
</script>
<script src="https://thestreamable.com/assets/js/google-analytics-outbound-links.js?v=5f9ca298"></script>
<aside id="newsletter-signup-bottom-sheet" hidden class="position-fixed bottom-0 left-0 right-0 pt-3 pt-sm-8 pb-3 pb-sm-4 px-3 anim-fade-up" style="z-index:29;background-image:radial-gradient(ellipse farthest-side at bottom center,rgba(36,41,46,0.9),rgba(36,41,46,0));">
<div class="position-relative container-sm box-shadow-extra-large border border-black-fade bg-gray-light pt-5 pb-5 pb-sm-6 px-5 rounded-3 text-center text-sm-left d-flex flex-column flex-sm-row flex-items-start flex-justify-center anim-fade-up" style="width:fit-content;">
<div class="mx-auto mb-2 mb-sm-0 mt-sm-3 mr-sm-4"><div class="mx-auto position-relative border-top border-gray-light rounded-2" style="width:54px;height:36px;">
<div class="rounded-2 position-absolute top-0 left-0 right-0 bottom-0 bg-gray-0 box-shadow" style="background-image:linear-gradient(#f6f8fa,#e1e4e8);"></div>
<div class="rounded-2 position-absolute top-0 left-0 right-0 bottom-0" style="border-width:27px 27px 9px;border-color:#d1d5da transparent transparent;border-style:solid;"></div>
<div class="rounded-2 position-absolute top-0 left-0 right-0 bottom-0" style="border-width:25px 27px 11px;border-color:#fafbfc transparent transparent;border-style:solid;"></div>
<div class="circle bg-site-red position-absolute" style="top:-8px;right:-8px;width:18px;height:18px;box-shadow:0 1px 0 rgba(27,31,35,0.15);"></div>
</div>
</div>
<div>
<div class="mb-3">
<h2 class="lh-condensed mb-1">Become a Streaming Insider!</h2>
<div class="text-gray f5">Get insider tips, top news stories, and the best streaming deals in your inbox.</div>
</div>
<form class="mb-n3" action="https://newsletter.thestreamable.com/subscribe" method="POST" accept-charset="utf-8" onsubmit="const emailField = document.getElementById('newsletter-sSIkbRnb-email-input'); emailField.value = emailField.value.trim();" target="_blank" rel="noopener">
<input id="newsletter-sSIkbRnb-email-input" class="form-control input-lg text-normal mb-3" name="email" type="email" placeholder="you@example.com" required 0="aria-label" 1="Email Address" oninput="document.getElementById('newsletter-sSIkbRnb-submit-button').disabled = !this.value.length;" />
<label class="d-none">HP<input name="hp" type="text" /></label>
<input type="hidden" name="list" value="QubTNq30QemE892pWRzIxJWQ" />
<input type="hidden" name="subform" value="yes" />
<input type="hidden" name="ReferralID" />
<button id="newsletter-sSIkbRnb-submit-button" class="ml-2 mb-3 btn btn-primary" type="submit" name="submit">Subscribe for Free</button>
</form>
<script type="module">
    const newsletterEmailField = document.getElementById('newsletter-sSIkbRnb-email-input');
    document.getElementById('newsletter-sSIkbRnb-submit-button').disabled = !newsletterEmailField.value;
    
</script>
</div>
<button type="button" class="lh-condensed-ultra close-button position-absolute top-2 right-2 text-gray" aria-label="Close">
<div class="p-1 bg-gray-light bg-gray-hover circle">
<svg width="16" height="16" viewBox="0 0 12 16" class="octicon octicon-x" aria-hidden="true"><path fill-rule="evenodd" d="M7.48 8l3.75 3.75-1.48 1.48L6 9.48l-3.75 3.75-1.48-1.48L4.52 8 .77 4.25l1.48-1.48L6 6.52l3.75-3.75 1.48 1.48L7.48 8z" /></svg>
</div>
</button>
</div>
</aside>
<script type="module">
const currentPopupVersion = 1;
const minimumIntersectionTime = 3000; // 3 sec
const dismissedPopupKey = 'newsletter-popup$dismissed';
const hasPopupBeenDismissed = parseInt(localStorage.getItem(dismissedPopupKey));

if (!hasPopupBeenDismissed || (hasPopupBeenDismissed < currentPopupVersion)) {
    const halfwayScrollTarget = document.getElementById('content-scroll-sentinel-halfway');
    const newsletterSignupSheet = document.getElementById('newsletter-signup-bottom-sheet');
    const signupForm = newsletterSignupSheet ? newsletterSignupSheet.getElementsByTagName('form')[0] : null;
    const closeButton = newsletterSignupSheet ? newsletterSignupSheet.getElementsByClassName('close-button')[0] : null;
    
    if (newsletterSignupSheet) {
        newsletterSignupSheet.addEventListener('click', function (event) {
            if (event.target == newsletterSignupSheet) {
                hideSheet();
            }
        });
    }
    if (closeButton) {
        closeButton.addEventListener('click', hideSheet);
    }
    if (signupForm) {
        signupForm.addEventListener('submit', hideSheet);
    }
    
    if (halfwayScrollTarget && newsletterSignupSheet) {
        const observer = new IntersectionObserver(function (entries) {
            const entry = entries[0];
            if (entry.isIntersecting && entry.time >= minimumIntersectionTime) {
                observer.unobserve(halfwayScrollTarget);
                newsletterSignupSheet.hidden = false;
            }
        }, {
            threshold: 1.0,
        });
        observer.observe(halfwayScrollTarget);
    }

    function hideSheet() {
        [newsletterSignupSheet, newsletterSignupSheet.getElementsByClassName('anim-fade-up')[0]].map((el) => {el.classList.remove('anim-fade-up'); el.classList.add('anim-fade-down');});
        
        try {
            localStorage.setItem(dismissedPopupKey, currentPopupVersion);
        }
        catch (e) {
        }
    }
}
</script>
</body>
</html>
